<!DOCTYPE HTML>
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://opengraph.org/schema/">
<head>
















  





  <!-- Always force latest IE rendering engine (even in intranet) & Chrome Frame -->
  <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

  <meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no, minimum-scale=1.0, maximum-scale=1.0">

  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  <meta http-equiv="Content-Language" content="en-AU">
  <meta name="abstract" content="Computerworld Australia is the leading source of technology news, analysis and tools for IT decision makers, managers and professionals.">
  <meta name="description" content="If your organisation is struggling to clear backlogs of integration projects, increase time to value and overcome resource and skills constraints, you’re not alone">
  <meta name="keywords" content="Gartner, artificial intelligence">
  <meta name="copyright" content="&copy; 2017 IDG Communications">
  <meta name="resource-type" content="document">
  <meta name="robots" content="index,follow, noarchive">
  
  <link rel="shortcut icon" href="https://d321cxw853vaeo.cloudfront.net/dimg/-1x-1//idg_sites/logos/computerworld.ico">
  
  
  <title>How to simplify integration using artificial intelligence - Computerworld</title>

  <script src="https://www.idgcdn.com.au/compressor-staticfiles/computerworld/modernizr.custom.js?release=20171129113953"></script>

<script type="text/javascript" src="//code.jquery.com/jquery-1.8.3.min.js"></script>
<link type="text/css" rel="stylesheet" media="all" href="https://www.idgcdn.com.au/compressor-staticfiles/rohan_world/rohan_world.css?release=20171129113953" crossorigin="anonymous">
<link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/brand_posts/style.css?release=20171129113953" media="screen,print" />




<meta property="fb:app_id" content="111663785542285" />
<meta property="og:site_name" content="Computerworld" />


<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '1724434721147660');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1724434721147660&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->


<link rel="alternate" type="application/rss+xml" title="Computerworld Australia" href="/rss/location/australia">





<script>
var _prum = [['id', '574e257cabe53d495e9c1b72'],
             ['mark', 'firstbyte', (new Date()).getTime()]];
(function() {
    var s = document.getElementsByTagName('script')[0]
      , p = document.createElement('script');
    p.async = 'async';
    p.src = '//rum-static.pingdom.net/prum.min.js';
    s.parentNode.insertBefore(p, s);
})();
</script>

<meta property="og:title" content="How to simplify integration using artificial intelligence" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://d321cxw853vaeo.cloudfront.net/article/images/800x800/dimg/artificial_intelligence.jpg" />
<meta property="og:url" content="https://www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/" />
<meta property="og:description" content="The need to connect applications, systems, endpoints and users in complex, multi-organisation ecosystems is growing" />

<!-- The below is the code for twitter cards for all the article pages -->




<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ComputerworldAU" />
<meta name="twitter:title" content="How to simplify integration using artificial intelligence" />

<meta name="twitter:image" content="https://d321cxw853vaeo.cloudfront.net/article/images/800x800/dimg/artificial_intelligence.jpg" />



<meta name="twitter:url" content="https://www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/" />






<meta name="news_keywords" content="Gartner, artificial intelligence">



<link rel="canonical" href="https://www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/" />


<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/magnific-popup.css?release=20171129113953" media="all" rel="stylesheet" type="text/css">

<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/comment.css?release=20171129113953" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/social.css?release=20171129113953" media="all" rel="stylesheet" type="text/css">

<link rel="alternate" type="application/rss+xml" title="Computerworld: Gartner" href="/rss/tag/gartner/" />

<link rel="alternate" type="application/rss+xml" title="Computerworld: artificial intelligence" href="/rss/tag/artificial-intelligence/" />

<link rel="alternate" type="application/rss+xml" title="Computerworld: by Eric Thoo, research director at Gartner" href="/rss/author/2147449641/eric-thoo-research-director-at-gartner/" />




<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/magnific-popup.css?release=20171129113953" media="all" rel="stylesheet" type="text/css">
<link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/article/article_imgheader.css?release=20171129113953" />
<script src="https://www.idgcdn.com.au/compressor-staticfiles/article/imgheader.js?release=20171129113953"></script>

</head>

<body class="lo-body lo-body_cw lo-responsive ">

<div id="headeradbox1x1">
</div>
<div id="otp_target"></div>
<div class="lo-top">
  <div class="lo-top_promo">
    <div class="lo-top_leaderboard">
      

<div class="gpt-ad" id="gpt-ad-top-banner-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[728, 90], [860, 155], [970, 250]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[728, 90], [[728, 90], [860, 155], [970, 250]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



    </div>
  </div>
  <header role="banner" class="lo-header" id="lo-header">
      
      <span class="lo-logo"><a href="/">Computerworld</a></span>
      
      
<div class="art-progress" id="art-progress">
	<div class="art-topbar_currect" id="art-topbar_currect">
		How to simplify integration using artificial intelligence
	</div>
	<div class="art-next" id="art-next">
		<a class="art-nextlink" id="art-nextlink" href="#"></a>
	</div>
</div>
<div class="lo-header_share_menu" id="lo-header_share_menu"></div>
<div class="art-progress_bar" id="art-progress_bar"></div>

      <!-- <div class="lo-header_icon lo-header_menu_button" id="lo-header_menu_button"></div> -->

      <div class="lo-header_menu_button" id="lo-header_menu_button">
        <span></span>
      </div>
      <div class="lo-header_menu_drawer">
        
        
        <nav class="lo-header_menu lo-header_nav">
          <ul>
            <li>
              <a href="/tax/news">News</a>
            </li>
            
            <li class="super">
              <a href="#">Technology</a>
              <div class="lo-header_sub lo-header_sub_technology sub three_col">
                <div class="lo-header_sub_content">
                  <ul>
                    <li class="hl"><a href="/tax/news">News</a></li>
                    <li><a href="/section/business">Business</a></li>
                    <li><a href="/section/cloud_computing">Cloud Computing</a></li>
                    <li><a href="/section/data_centre">Data Centre</a></li>
                    <li><a href="/section/gaming_dev">Gaming Dev</a></li>
                    <li><a href="/section/government">Government</a></li>
                    <li><a href="/section/infrastructure/">Infrastructure</a></li>
                  </ul>
                  <ul>
                    <li><a href="/section/mobility_wireless">Mobility</a></li>
                    <li><a href="/section/networking">Networking</a></li>
                    <li><a href="/section/open_source">Open Source</a></li>
                    <li><a href="/section/security">Security</a></li>
                    <li><a href="/section/servers">Servers</a></li>
                    <li><a href="/section/social_networking">Social Networking</a></li>
                    <li><a href="/section/software/">Software</a></li>
                  </ul>
                  <ul>
                    <li><a href="/section/software_development">Software Development</a></li>
                    <li><a href="/section/storage">Storage</a></li>
                    <li><a href="/section/tech_planet">Tech Planet</a></li>
                    <li><a href="/section/telecommunications">Telecoms</a></li>
                    <li><a href="/tax/tutorials">Tutorials</a></li>
                    <li><a href="/section/unified_communications">Unified Comms</a></li>
                    <li><a href="/section/virtualisation">Virtualisation</a></li>
                  </ul>
                </div>
              </div>
            </li>
            
            
            <li class="super">
              <a href="#">Tools</a>
              <div class="lo-header_sub lo-header_sub_tools sub three_col">
                <div class="lo-header_sub_content">
                  <ul>
                    <li><a href="/blog/">Blogs</a></li>
                    <li><a href="/contacts">Editorial Contacts</a></li>
                    <li><a href="/event">Events</a></li>
                    <li><a href="/mediareleases/">IT Media Releases</a></li>
                    <li><a href="/user/register/?referrer=nav_resources">Join Computerworld</a></li>
                  </ul>
                  <ul>
                    <li><a href="/user/mailing_list/?referrer=nav_resources">Newsletters</a></li>
                    <li><a href="/nbn/">NBN</a></li>
                    <li><a href="/rss/">RSS</a></li>
                    <li><a href="/slideshow/">Slideshows</a></li>
                    <li><a href="/section/opinions/vendor_view/">Vendor View</a></li>
                  </ul>
                  <ul>
                    <li><a href="/video/">Videos</a></li>
                    <li><a href="/zones">Zones</a></li>
                    <li><a href="/jobs/">Jobs</a></li>
                  </ul>
                </div>
              </div>
            </li>
            
            
            <li class="super">
              <a href="#">Whitepapers</a>
              <div class="lo-header_sub lo-header_sub_whitepapers sub three_col">
                <div class="lo-header_sub_content">
                  <ul>
                    <li class="hl"><a href="/section/featured_whitepapers">All Whitepapers</a></li>
                    <li><a href="/whitepaper/tag/business%20management">Business + Management</a></li>
                    <li><a href="/whitepaper/tag/Cloud%20Computing">Cloud Computing</a></li>
                    <li><a href="/whitepaper/tag/CRM">CRM</a></li>
                    <li><a href="/whitepaper/tag/Data%20Centre">Data Centre</a></li>
                  </ul>
                  <ul>
                    <li><a href="/whitepaper/tag/master%20data%20management">Data Management</a></li>
                    <li><a href="/whitepaper/tag/disaster%20recovery">Disaster Recovery</a></li>
                    <li><a href="/whitepaper/tag/network">Network</a></li>
                    <li><a href="/whitepaper/tag/security">Security</a></li>
                    <li><a href="/whitepaper/tag/storage">Storage</a></li>
                  </ul>
                  <ul>
                    <li><a href="/whitepaper/tag/Telecommunications">Telecommunications</a></li>
                    <li><a href="/whitepaper/tag/unified%20communications">Unified Communications</a></li>
                    <li><a href="/whitepaper/tag/virtualisation">Virtualisation</a></li>
                    <li><a href="/whitepaper/tag/Wireless">Wireless</a></li>
                    <li><a href="/section/featured_whitepapers">Other Whitepapers</a></li>
                  </ul>
                </div>
              </div>
            </li>
            
          </ul>
        </nav>
        
        <div class="lo-header_menu lo-header_action">
          <ul>
            <li class="user super">
            
            
              <a class="lo-header_icon lo-header_user lo-header_login" href="#">Login</a>
              <div class="lo-header_sub lo-header_sub_user sub lo-sub_login">
                <form class="lo-header_sub_content" action="/user/login/" accept-charset="UTF-8" method="get" id="user-login-form"><input type='hidden' name='csrfmiddlewaretoken' value='iNhX2j2IWdejOIJq75OGyFkctSbMx0ATlXFmtkXPGolBRWqkGPrT3vbqF00amLH7' />

                   <input type="submit" value="Log in" id="login-submit" name="op">
                   <p><a id="login-forgot" href="/user/password/">Forgot password?</a></p>
                  <p><a href="/user/register/?location=top_nav_bar">Sign up now</a> to get free exclusive access to reports, research and invitation only events.</p>
                 </form>
              </div>
              
            
            </li>
            <li class="search">
              <div class="lo-header_search" id="lo-header_search">
                <span class="lo-header_search_button"></span>

                <div id="lo-header_search_form">
                  <form action="/search/" method="get">
                    <input class="lo-header_search_text" id="lo-header_search_text" type="search" placeholder="Search" name="q">
                    <input class="lo-header_search_submit" id="lo-header_search_submit" type="submit" name="sa" value="Search">
                  </form>
                </div>
              </div>
            </li>
          </ul>
        </div>
        
<div class="lo-header_menu lo-header_social">
	<ul>
		<li class="lo-header_social_li"><a class="lo-header_social_icon lo-header_twitter" target="_blank" href="https://twitter.com/computerworldau">Twitter</a></li>
		<li class="lo-header_social_li"><a class="lo-header_social_icon lo-header_facebook" target="_blank" href="https://www.facebook.com/computerworld.australia">Facebook</a></li>
	</ul>
</div>

      </div>

  </header>
</div>

<div class="lo-noskin_bump" id="noskin_bump"></div>

<div id="skin" class="lo-skin">
<div id="main" class="lo-content skin_wrap">
  <div id="content_wrap">
        
        <div class="lo-columns " id="site_columns">
    
    <div class="lo-column lo-main" id="site_columns_main">
      
<div id="art-articles_wrap" class="art-articles_wrap art-articles_wrap_infinite">

  

  <div id="art-next_signifier" class="art-next_signifier">
    <div class="art-next_signifier_content">
      <span class="art-next_signifier_image" id="art-next_signifier_image"></span>
      <h3 class="art-next_signifier_title" id="art-next_signifier_title"></h3>
    </div>
  </div>


  

  <div itemscope itemtype="http://schema.org/Article" class="art-wrap article_wrap" id="article_wrap_630516" data-article-id="630516" data-article-headline="How to simplify integration using artificial intelligence" data-article-url="/article/630516/how-simplify-integration-using-artificial-intelligence/">

    <meta itemprop="sourceOrganization" content="Computerworld" />
    <article class="art-article full">

      
      <header class="art-header art-header_imgheader">
        <div class="art-header_wrap">
          <div class="art-header_content">
            <h1 itemprop="name" class="art-title">How to simplify integration using artificial intelligence</h1>
            <div class="art-sms_wrap"><p class="art-sms sms">If your organisation is struggling to clear backlogs of integration projects, increase time to value and overcome resource and skills constraints, you’re not alone</p></div>
          </div>

          
          
          <div class="art-header_image_thumbnail">
            <img alt="" src="https://d321cxw853vaeo.cloudfront.net/article/images/100x100/dimg/artificial_intelligence.jpg" data-adaptive-background>
          </div>
          <div class="art-header_background">
            <svg class="art-header_svg" width="400" height="300" baseProfile="full" version="1.2">
              <defs>
                <linearGradient id="art-fadeGrad" y2="0" x2="1">
                  <stop offset="0" stop-color="white" stop-opacity="0"/>
                  <stop offset="0.5" stop-color="white" stop-opacity="1"/>
                  <stop offset="1" stop-color="white" stop-opacity="1"/>
                </linearGradient>
                <mask id="art-fade" class="art-fade" maskContentUnits="objectBoundingBox">
                  <rect width="1" height="1" fill="url(#art-fadeGrad)"/>
                </mask>

                <linearGradient id="art-fadeGradVertical" y2="1" x2="0">
                  <stop offset="0" stop-color="white" stop-opacity="0"/>
                  <stop offset="0.5" stop-color="white" stop-opacity="1"/>
                  <stop offset="1" stop-color="white" stop-opacity="1"/>
                </linearGradient>
                <mask id="art-fade_vertical" class="art-fade_vertical" maskContentUnits="objectBoundingBox">
                  <rect width="1" height="1" fill="url(#art-fadeGradVertical)"/>
                </mask>

              </defs>


              <image class="art-header_background_image" width="100%" height="100%" preserveAspectRatio="xMaxYMin slice" xlink:href="https://d321cxw853vaeo.cloudfront.net/article/images/600x400/dimg/artificial_intelligence.jpg"/>

              <div class="art-header_caption">
              

              
              </div>
            </svg>
          </div>
          
          
        </div>

        
        

        
        



<div class="art-social article_social" id="article_social_0" data-article-id="630516" data-article-url="https://www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/">
	<div class="art-byline">

		
			<a class="art-author_pic" href="/author/2147449641/eric-thoo-research-director-at-gartner/articles">
			
				<img src="https://www.idgcdn.com.au/compressor-staticfiles/cio/images/author_placeholder.png?release=20171129113953">
			
			</a>
		

		<span class="art-author">
		
			<a href="/author/2147449641/eric-thoo-research-director-at-gartner/articles">Eric Thoo, research director at Gartner (Computerworld)</a>
		
		</span>

		
			<span class="art-date" itemprop="datePublished">28 November, 2017 11:31</span>
		
	</div>

	<ul class="art-share">
		<!-- <li class="comments_li"><a class="comments" href="#comments" data-disqus-identifier="/article/630516/">0</a></li> -->
		<li class="facebook_li"><a data-action="Like" data-label="Facebook" target="_blank" class="facebook" href="http://www.facebook.com/sharer.php?u=http%3A//www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/&amp;amp;t=How%20to%20simplify%20integration%20using%20artificial%20intelligence">-</a></li>
		<li class="linkedin_li"><a data-action="share" data-label="LinkedIn" target="_blank" class="linkedin" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A//www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/&amp;title=How%20to%20simplify%20integration%20using%20artificial%20intelligence">-</a></li>
		<li class="twitter_li"><a data-action="Tweet" data-label="Twitter" target="_blank" class="twitter" href="http://twitter.com/share?text=How%20to%20simplify%20integration%20using%20artificial%20intelligence&amp;url=http%3A//www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/">-</a></li>
		<li class="gplus_li"><a data-action="+1" target="_blank" data-label="Google+" class="gplus" href="https://plus.google.com/share?url=http%3A//www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/">-</a></li>
		
		<li class="print_li"><a class="line print" title="print this article" href="/article/print/630516/how-simplify-integration-using-artificial-intelligence/" rel="nofollow">print</a></li>
		
		<li class="email_li"><a class="line email" title="email this article" href="mailto:?subject=How%20to%20simplify%20integration%20using%20artificial%20intelligence&amp;amp;body=http%3A//www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/">email</a></li>
	</ul>
</div>
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/social.js?release=20171129113953"></script>
<script>
// var social_float_disable = true;
</script>

        

        
        

      </header>
      

      <div class="art-header_extra">
        
        <a href="#art-comments_630516" data-disqus-identifier="/article/630516/" class="art-comment_count">Comments</a>
      </div>

      <div itemprop="articleBody" class="art-body body">


      
      
      
      
      
      
      

      
      










	
<p>The need to connect applications, systems, endpoints and users in complex, multi-organisation ecosystems is growing. This is forcing integration to become pervasive, which is a critical but complex competency that’s now foundational to enabling digital business transformation. Application leaders responsible for integration are having to empower almost every member of their organisation to make this new reality happen.
  </p><p>If your organisation is struggling to clear backlogs of integration projects, increase time to value and overcome resource and skills constraints, you’re not alone. Making pervasive integration capabilities adaptable, at scale and extensive, compels integration teams to seek new ways of accomplishing more with less. As the number of integration technologies continues to expand, making independently designed applications and data structures work together remains a complex challenge for enterprises.   </p><p>If you’re seeking simpler ways to integrate applications into the enterprise, consider introducing integration platforms armed with artificial intelligence (AI) capabilities.
  </p><p><strong>AI-enabled integration</strong>
</p><p>Several integration technology providers have already AI-enabled their platforms to simplify the development of integration flows, shorten the learning curve, lower skills requirements and assist in the execution of integration processes.
  </p><aside id="brand-post-promo-placeholder-slot"></aside>
<p>Some targeted, early business benefits of using AI in integration include:
  </p><ul><li>Lowering time and cost of integration by reducing usage complexity, and empowering less-technical roles to solve integration problems. For example, equipping business users to carry out integration tasks without or with minimal support from professional developers or integration specialists.
  </li><li>Assisted access to a range of pre-packaged and configurable AI-infused integration artefacts for optimal alignment, as well as the deployment of application and data integration tasks through intuitive, guided designs.
  </li><li>Conversational user experiences expedite efficiencies by assisting the creation of integration process or querying the operational state of the integration platform. This enables line-of-business leaders to connect systems and use independently designed applications and data structures as integrated solutions.
  </li></ul><p>At this early stage, AI in integration platforms is beginning to bring together diverse, commonly required integration functionality. Some iPaaS providers – such as Dell Boomi's Boomi Suggest, Informatica's CLAIRE, SnapLogic's Iris Artificial Intelligence and Workato's Workbot – take advantage of their "integration eye in the sky" on cloud-native platforms and offer AI-enabled recommendations for integration development approaches based on collective patterns.   </p><p><strong>Build recommendation engines</strong>
</p><aside class="readmore">
<div class="nocontent">
<a class="image" href="https://www.computerworld.com.au/article/630410/citizen-tech-fears-putting-economy-risk-foreign-policy-white-paper/"><img src="https://d321cxw853vaeo.cloudfront.net/dimg/120x120/dimg/dreamstime_m_38726983.jpg"/></a>
<span class="text"><strong>Read more</strong> <a href="https://www.computerworld.com.au/article/630410/citizen-tech-fears-putting-economy-risk-foreign-policy-white-paper/">Citizen tech fears putting economy at risk: Foreign policy white paper</a></span>
</div>
</aside>
<p>A prominent use of AI at present is to enable business roles to perform integration. This is provided through metadata sharing and analysis to build recommendation engines that automate the integration process.
  </p><p>Embedded in integration platforms, recommendation engines have the ability to use graph and cluster analyses on data usage characteristics. This is done by analysing things such as the frequency of data access by data type (how data is stored – via relational, object, document and other structures); the affinity of service components (which data is put together into query objects or mined to create query objects); and the identification of user credentials and job roles involved.
  </p><p><strong>Emergence of digital integrator technologies</strong>
</p><p>AI techniques applied to integration are emerging as digital integrator technologies — that is, innovations that set out to facilitate the resolution of complex integration problems, including challenges of a scale that would not be addressable by conventional approaches.
  </p><aside class="readmore">
<div class="nocontent">
<a class="image" href="https://www.computerworld.com.au/article/630106/machine-learning-driven-pricing-could-undermine-competition-accc-warns/"><img src="https://d321cxw853vaeo.cloudfront.net/dimg/120x120/dimg/data_data_data_2.jpg"/></a>
<span class="text"><strong>Read more</strong> <a href="https://www.computerworld.com.au/article/630106/machine-learning-driven-pricing-could-undermine-competition-accc-warns/">Machine learning driven pricing could undermine competition, ACCC warns</a></span>
</div>
</aside>
<p>Some functional characteristics of digital integrator technologies, such as making recommendations to improve the performance of your integration flow execution, are visible to integration developers. While others, such as helping integration tooling optimise its platform operations, are invisible to developers. These evolving innovations have far-reaching implications in terms of achieving the key dimensions of pervasive integration.   </p><p>With AI-guided recommendation engines that use machine learning and inference algorithms to deliver step-by-step guidance, building data pipelines and application flows will ideally become an increasingly intuitive effort. This guidance allows diverse personas to use the recommendations of the AI engine to automate highly repetitive integration tasks, which expedites the clearance of integration backlogs that currently worry integration teams.   </p><p>As the need to use diverse endpoints, deployment models and various integration patterns increases, the integration pipelines inferred by AI engines with access to discovered metadata, tagging and inferred analysis, can provide lessons to streamline and suggest which options to use when integrating applications and data.
  </p><p>This use of AI inside integration software potentially shortens the learning curve of both specialist and less technical integrators to manage data and business flows. This enables an extensive range of roles to perform integration tasks to pervasively address needs.   </p><aside class="readmore">
<div class="nocontent">
<a class="image" href="https://www.computerworld.com.au/article/630042/pact-group-eyes-ai-workplace-safety-boost/"><img src="https://d321cxw853vaeo.cloudfront.net/dimg/120x120/dimg/vision_webcam.jpg"/></a>
<span class="text"><strong>Read more</strong> <a href="https://www.computerworld.com.au/article/630042/pact-group-eyes-ai-workplace-safety-boost/">Pact Group eyes AI for workplace safety boost</a></span>
</div>
</aside>
<p>The use of AI techniques to power integration platforms and complement human capability is on the rise. Plan now for investigating, developing or further extending your integration competencies and technologies to engage in connected infrastructures and systems by including AI as part of your integration strategies and infrastructure.
  </p><p><a href="https://www.gartner.com/analyst/30247"><em>Eric Thoo</em></a><em> is a research director at Gartner, advising clients on data integration practices and technologies. He will speak about data integration strategy at the </em><a href="https://www.gartner.com/events/apac/data-analytics"><em>Gartner Data &amp; Analytics Summit</em></a><em> in Sydney on 26-27 February 2018.</em>
</p><p></p>
<div class="nocontent">
<b>Read more: </b><a href="https://www.computerworld.com.au/article/630552/cba-preparing-machine-to-machine-economy/">CBA preparing for ‘machine-to-machine economy’</a>
</div>





      
      

        
      



<aside class="readmore" id="brand-post-in-article-promo">
	<div class="nocontent">
	<a class="image placeholder" href="/brand-post/content/628470/samsung-portable-ssd-t5-picture-this-light-and-fast-portable-storage/" onclick="trackBrandPostNativeAdLink();">
		<img src="https://d321cxw853vaeo.cloudfront.net/brand-post/logo/230x230/dimg/samsung_1.png" />
	</a>

	<span class="text">
		<img class="brandpost_logo" src="https://d321cxw853vaeo.cloudfront.net/dimg/90x30/brand_post/post_type/brandpost_type.png">
		<a href="/brand-post/content/628470/samsung-portable-ssd-t5-picture-this-light-and-fast-portable-storage/" onclick="trackBrandPostNativeAdLink();">Samsung Portable SSD T5: Picture This - Light and fast portable storage</a><br/>
	</span>

	<a class="more" href="/brand-post/4/samsung/" onclick="trackBrandPostNativeAdLink();">More from Samsung</a>

	
	</div>
</aside>

<script type="text/javascript">
$(document).ready(function() {
	if(document.getElementById("brand-post-promo-placeholder-slot") !== null) {
		insertBrandPostReadMoreSlot();
	} else {
		insertBrandPostArticleMiddle();
	}
});

function insertBrandPostReadMoreSlot() {
	$('#brand-post-promo-placeholder-slot').replaceWith($('#brand-post-in-article-promo'));
}

function insertBrandPostArticleMiddle() {
	var pos = $('article.full .body > .storybody').length;
	if (pos > 5) {
		pos = Math.round(pos / 2);
	}
	
	$('article.full .body > .storybody').each(function(index, object){	
		if (index == pos) {
			$(this).after($('#brand-post-in-article-promo'));
		}
	});
}

function trackBrandPostNativeAdLink() {
	ga("send", "event", 'Brand Posts', 'Brand Post native ad click', 'brand-post-nid-628470', {'nonInteraction': 1});
}
</script>


      


      
      

      
      <div id="quick-signup-article-widget">


<div class="qs-article_widget">
	<h3>Join the  newsletter!</h3>
	<!-- <small>Computerworld&#39;s twice-daily news service keeps you in touch with the latest, most important headlines from Australia and around the world.</small> -->

	<form id="qs-article" action="/newsletter/quick-subscription/">
		
		<input id="id_newsletter" name="newsletter" type="hidden" value="28" />
		<input type="hidden" value="https://www.computerworld.com.au/article/630516/how-simplify-integration-using-artificial-intelligence/" name="signup_url">

		

		<div class="qs-anonymous" id="qs-anonymous">
			<input class="qs-textfield" id="id_email" name="email" placeholder="Email address" type="email" required />
			<button type="button" class="qs-btn primary" id="qs-btn_anonymous">Join</button>
		</div>
	</form>

	<div class="qs-message" id="qs-message">Error: Please check your email address.</div>
</div>

<script type="text/javascript">
$(document).ready(function() {
	var wrap = $('.qs-article_widget');
	wrap.css('background', wrap.data('color-initial'));
	
	var form = $('#qs-article');
	
	$('#qs-btn_change_email').click(function() {
		$('#qs-registered').slideUp();
		$('#qs-anonymous').slideDown();
	});
	
	$('#qs-btn_anonymous, #qs-btn_registered', form).click(function() {
		form.submit();
	});
	
	// $("#qs-message").click(function() {
	// 	$(this).fadeOut();
	// });
	
	form.submit(function(e) {
		e.preventDefault();
		
		var data = {};
		$('#qs-article').serializeArray().map(function(x) {
			data[x.name] = x.value;
		});
		
		$('#qs-message').hide();
		
		$.ajax({
			url: form.attr('action'),
			type: 'POST',
			dataType: 'json',
			data: data,
			error: function(xhr) {
				var data = JSON.parse(xhr.responseText);
				alert(data.message);
			},
			success: function(data) {
				if (data.success) {
					$('#id_email', form).val('');
					// wrap.css('background-color', wrap.data('color-success'));
					// $('#qs-message').css('color', wrap.data('color-success'));
					$('#qs-registered, #qs-anonymous').slideUp();
				}
				$('#qs-message').html(data.message).slideDown();
			}
		});
	});
});
</script>


</div>

      


        
      
      <p class="tags">
        Tags <a href="/tag/gartner/">Gartner</a><a href="/tag/artificial-intelligence/">artificial intelligence</a>
      </p>
      
      
      
      
      
        
      
      <p class="tags companies">
        More about <a href="/company//"></a><a href="/company/dell/">Dell</a><a href="/company/dell_boomi/">Dell Boomi</a><a href="/company/gartner/">Gartner</a><a href="/company/informatica/">Informatica</a>
      </p>
      
      
      
      



      









      </div><!-- body -->

    </article>


    <div class="art-sidebar">
      
      
    
    
    <div class="lo-rhs_mrec boombox">
<div class="gpt-ad" id="gpt-ad-right-hand-side-story-list-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[300, 600], [300, 250]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="CW Featured WP 300x250" data-min-width="None">

	
		<iframe src="https://www.computerworld.com.au/whitepaper_ad/boombox/" width=300 height=250 border=0 marginheight="0" marginwidth="0" frameborder="0" scrolling=no></iframe>
	

</div>

</div>
    
    

    




<aside class="lo-rhs_box lo-rhs_readmore read_more">
	<h2 class="lo-subheader lo-rhsheader">Editor's Recommendations</h2>
	<ul class="lo-list related_list">
	
		<li>
			<a class="lo-list_image image" href="/article/630574/victoria-police-relying-on-obsolete-tech/">
			<img src="https://d321cxw853vaeo.cloudfront.net/promoted-content/image/80x50/dimg/magnifying_glass_computer_9.jpg">
			</a>
			<h3 class="lo-list_title"><a href="/article/630574/victoria-police-relying-on-obsolete-tech/">Victoria Police relying on obsolete tech</a></h3>
		</li>
	
		<li>
			<a class="lo-list_image image" href="/article/630562/report-details-metadata-failures-at-afp/">
			<img src="https://d321cxw853vaeo.cloudfront.net/promoted-content/image/80x50/dimg/privacy_big_brother_27.jpg">
			</a>
			<h3 class="lo-list_title"><a href="/article/630562/report-details-metadata-failures-at-afp/">Report details ‘metadata’ failures at AFP</a></h3>
		</li>
	
		<li>
			<a class="lo-list_image image" href="/article/630463/nbn-puts-hfc-rollout-hold/">
			<img src="https://d321cxw853vaeo.cloudfront.net/promoted-content/image/80x50/dimg/bill_morrow_credit_nbnco_4.jpg">
			</a>
			<h3 class="lo-list_title"><a href="/article/630463/nbn-puts-hfc-rollout-hold/">NBN puts HFC rollout on hold</a></h3>
		</li>
	
		<li>
			<a class="lo-list_image image" href="/article/630477/telcos-seek-clarity-about-governments-new-data-access-regime/">
			<img src="https://d321cxw853vaeo.cloudfront.net/promoted-content/image/80x50/dimg/data_mesh.jpg">
			</a>
			<h3 class="lo-list_title"><a href="/article/630477/telcos-seek-clarity-about-governments-new-data-access-regime/">Telcos seek clarity about government’s new data access regime</a></h3>
		</li>
	
		<li>
			<a class="lo-list_image image" href="/article/630448/government-to-legislate-individuals-right-to-access-their-data/">
			<img src="https://d321cxw853vaeo.cloudfront.net/promoted-content/image/80x50/dimg/data_____9.jpg">
			</a>
			<h3 class="lo-list_title"><a href="/article/630448/government-to-legislate-individuals-right-to-access-their-data/">Government to legislate individuals’ right to access their data</a></h3>
		</li>
	
		<li>
			<a class="lo-list_image image" href="/article/630418/nbn-maybe-possibly-might-release-speed-database-perhaps/">
			<img src="https://d321cxw853vaeo.cloudfront.net/promoted-content/image/80x50/dimg/broadband_speeds_1_5.jpg">
			</a>
			<h3 class="lo-list_title"><a href="/article/630418/nbn-maybe-possibly-might-release-speed-database-perhaps/">NBN maybe possibly might release speed database, perhaps</a></h3>
		</li>
	
	</ul>
</aside>





    
      <a class="cio50-rhspromo" href="https://recruitment.idg.com.au/"><img src="https://demo.idg.com.au/idg_recruitment/banner_recruitment.gif"></a>
    

    

    
    
    
    
    
    
    
    
    
    

    

    
    
    
                
    <aside class="lo-rhs_box lo-rhs_readmore read_more">
            <h2 class="lo-subheader lo-rhsheader">Web Events</h2>
            <ul class="lo-list rhs-web-event">
                  
                          <li>
                                  <a class="lo-list_image image" href="/webinar/365664/computerworld-live-webinar-storage-momentum-the-next-chapter/video/"><img src="https://d321cxw853vaeo.cloudfront.net/webinar/images/sponsor/75x75/webinars/sponsor_logo/computerworld-live-webinar-storage-momentum-the-next-chapter_dellemc.png" alt="" /></a>
                                  <a href="/webinar/365664/computerworld-live-webinar-storage-momentum-the-next-chapter/video/"><h3>Computerworld Live Webinar | Storage momentum - the ‘next chapter’</h3></a>
                          </li>
                   
                          <li>
                                  <a class="lo-list_image image" href="/webinar/365663/digital-transformation-and-the-e-signature-momentum/video/"><img src="https://d321cxw853vaeo.cloudfront.net/webinar/images/sponsor/75x75/webinars/sponsor_logo/digital-transformation-and-the-e-signature-momentum_esignlive.png" alt="" /></a>
                                  <a href="/webinar/365663/digital-transformation-and-the-e-signature-momentum/video/"><h3>Digital transformation and the e-signature momentum</h3></a>
                          </li>
                   
                          <li>
                                  <a class="lo-list_image image" href="/webinar/365658/cio-computerworld-live-webinar-why-cyber-resilience-is-your-best-defence/video/"><img src="https://d321cxw853vaeo.cloudfront.net/webinar/images/sponsor/75x75/webinars/sponsor_logo/cio-computerworld-live-webinar-why-cyber-resilience-is-your-best-defence_mimecast.png" alt="" /></a>
                                  <a href="/webinar/365658/cio-computerworld-live-webinar-why-cyber-resilience-is-your-best-defence/video/"><h3>CIO &amp; Computerworld Live Webinar | Why cyber resilience is your best defence</h3></a>
                          </li>
                   

            </ul>
    </aside>
    

    
    
    
    

    
    
    <div class="lo-rhs_box">
<div class="gpt-ad" id="gpt-ad-right-hand-side-boombox-standard-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[300, 600], [300, 250]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="CW Featured WP 300x250" data-min-width="None">

	
		<iframe src="https://www.computerworld.com.au/whitepaper_ad/boombox/" width=300 height=250 border=0 marginheight="0" marginwidth="0" frameborder="0" scrolling=no></iframe>
	

</div>

</div>
    
    


    


    



<aside class="lo-rhs_box">
	<h2 class="lo-subheader">Related Whitepapers</h2>
	<ul class="related_list whitepapers">
	
	
	<li>
		<a class="image" href="/whitepaper/373758/the-iot-empowers-people-with-chronic-diseases-to-achieve-quality-of-life/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper"><img src="https://d321cxw853vaeo.cloudfront.net/whitepaper/thumbnail/40x60/whitepapers/thumbnails/livingo.png" /></a>
		<h3><a href="/whitepaper/373758/the-iot-empowers-people-with-chronic-diseases-to-achieve-quality-of-life/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper">The IoT Empowers People with Chronic Diseases to Achieve Quality of Life</a></h3>
	</li>
	
	
	<li>
		<a class="image" href="/whitepaper/373754/gartner-guide-to-iot-vendor-selection/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper"><img src="https://d321cxw853vaeo.cloudfront.net/whitepaper/thumbnail/40x60/whitepapers/thumbnails/gartner_guide_to_vendor_selection.png" /></a>
		<h3><a href="/whitepaper/373754/gartner-guide-to-iot-vendor-selection/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper">Gartner Guide to IoT Vendor Selection</a></h3>
	</li>
	
	
	<li>
		<a class="image" href="/whitepaper/373750/the-cios-it-transformation-survival-guide/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper"><img src="https://d321cxw853vaeo.cloudfront.net/whitepaper/thumbnail/40x60/whitepapers/thumbnails/it_survival_guide.png" /></a>
		<h3><a href="/whitepaper/373750/the-cios-it-transformation-survival-guide/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper">The CIO&#39;s IT Transformation Survival Guide</a></h3>
	</li>
	
	
	<li>
		<a class="image" href="/whitepaper/373740/the-cost-of-cloud-expertise/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper"><img src="https://d321cxw853vaeo.cloudfront.net/whitepaper/thumbnail/40x60/whitepapers/thumbnails/rackspace.png" /></a>
		<h3><a href="/whitepaper/373740/the-cost-of-cloud-expertise/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper">The cost of cloud expertise</a></h3>
	</li>
	
	</ul>
</aside>



  
      
    </div>



    <div class="art-extra">

    
    <div class="art-comments" id="art-comments_630516">
    <a class="art-comment_show" data-disqus-identifier="/article/630516/" data-disqus-shortname="computerworldau" href="#">Show Comments</a>
<div id="disqus_thread" data-disqus-shortname="computerworldau" data-disqus-identifier="/article/630516/"></div>
<script type="text/javascript">
var disqus_shortname = 'computerworldau';
var disqus_identifier = '/article/630516/';
var disqus_init = false;
function disqus_config() {
	this.callbacks.onReady = [function() {
		if (disqus_init) return;
		disqus_init = true;

		if ($('.art-articles_wrap_infinite').length == 0) return;

		var comment_text = $('.art-comment_show').first().text();
		if (comment_text == '0 Comments') {
			$(".art-comment_show_activated").removeClass("art-comment_show_activated");
			$('#disqus_thread').hide();
		}
	}];
}

(function() {
	$('.art-comment_show').first().addClass('art-comment_show_activated');
	var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
	dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
	(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>

    </div>
      



      

      
      <div class="lo-bottom_boombox bottom_boombox">
      
<div class="gpt-ad" id="gpt-ad-main-column-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[300, 600], [300, 250]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="CW Featured WP 300x250" data-min-width="None">

	
		<iframe src="https://www.computerworld.com.au/whitepaper_ad/boombox/" width=300 height=250 border=0 marginheight="0" marginwidth="0" frameborder="0" scrolling=no></iframe>
	

</div>


      </div>
      


      <!-- <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/article.js?release=20171129113953"></script> -->

      



      
<script type="text/javascript">
(function() {
  var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
  po.src = 'https://apis.google.com/js/plusone.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
})();
</script>



    </div>

    
    
    <aside class="art-readnext readnext">
      <h2>Read next</h2>
      <ul>
        
        
        
        <li>
          
          
          

          <a class="image" href="/article/630418/nbn-maybe-possibly-might-release-speed-database-perhaps/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20171129113953" data-src="https://d321cxw853vaeo.cloudfront.net/article/images/300x300/dimg/broadband_speeds_1_5.jpg"></a>
          <h3><a href="/article/630418/nbn-maybe-possibly-might-release-speed-database-perhaps/">NBN maybe possibly might release speed database, perhaps</a></h3>

          

        </li>
        
        <li>
          
          
          

          <a class="image" href="/article/630483/waternsw-begins-hunt-new-cio/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20171129113953" data-src="https://d321cxw853vaeo.cloudfront.net/article/images/300x300/dimg/gordon_dunsford_1.jpg"></a>
          <h3><a href="/article/630483/waternsw-begins-hunt-new-cio/">WaterNSW begins hunt for new CIO</a></h3>

          

        </li>
        
        <li>
          
          
          

          
          <a class="image" href="http://www.cso.com.au/article/630493/uk-nhs-spends-35m-new-security-ops-centre-response-wannacry/?utm_medium=leapfrog&amp;utm_source=www.computerworld.com.au"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20171129113953" data-src="https://d321cxw853vaeo.cloudfront.net/article/images/300x300/dimg/dreamstime_s_93189250.jpg"></a>
          
          <h3><a href="http://www.cso.com.au/article/630493/uk-nhs-spends-35m-new-security-ops-centre-response-wannacry/?utm_medium=leapfrog&amp;utm_source=www.computerworld.com.au">UK’s NHS spends $35m on new security ops centre in response to ...</a></h3>
          <p class="featured_on">CSO Online</p>

          

        </li>
        
        

        
        
        
        
        <li class="gallery">
          <a class="image" href="/slideshow/630020/pictures-why-some-apps-aren-t-fit-cloud-melbourne-roundtable/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20171129113953" data-src="https://d321cxw853vaeo.cloudfront.net/article/images/300x300/dimg/cio_vue_de_monde_09-11-17-11.jpg"></a>
          <h3><a href="/slideshow/630020/pictures-why-some-apps-aren-t-fit-cloud-melbourne-roundtable/">In pictures: Why some apps aren’t fit for the cloud - Melbourne ...</a></h3>
        </li>
        
        
        
        <li class="gallery">
          <a class="image" href="/slideshow/627297/pictures-hpc-meets-ai-world-possibilities/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20171129113953" data-src="https://d321cxw853vaeo.cloudfront.net/article/images/300x300/dimg/idg-cw-lenovo-lunch-004.jpg"></a>
          <h3><a href="/slideshow/627297/pictures-hpc-meets-ai-world-possibilities/">In pictures: HPC meets AI - a world of possibilities</a></h3>
        </li>
        
        
        
      </ul>
    </aside>
    
    


    
    
    


    
    



<div class="ias-pagination" id="ias-pagination_630516">
	<a class="ias-next" data-sms="Concerns over R&amp;D bill that would allow exemptions from the majority of the state’s laws to be granted" data-image="https://d321cxw853vaeo.cloudfront.net/dimg/200x200/dimg/south_australia_1.jpg" title="South Australian bill could let tech companies ignore laws" data-article-nextid="630525" href="/article/630525/south-australian-bill-could-let-tech-companies-ignore-laws/">South Australian bill could let tech companies ignore laws</a>
</div>

    



  </div><!-- art-wrap -->




</div><!-- art-articles_wrap -->












    </div><!-- lo-main -->
    

  


  </div><!-- site_columns -->
  <div id="site_columns_bottom"></div>  










<section class="lo-marketplace">
	<h2 class="lo-marketplace_header">Market Place</h2>
	<ul class="lo-marketplace_list">
	
		<li class="lo-marketplace_item">
			<a class="lo-marketplace_image" href="https://ad.doubleclick.net/ddm/clk/403652017;203869784;k" rel="nofollow" target="_blank" onClick="trackEvent('Marketplace', 'Click', '1968 Tableau Software');" >
				<img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20171129113953" data-src="https://d321cxw853vaeo.cloudfront.net/marketplace/100x42/marketplace/tableau_logo_2.jpg" />
			</a>
			<a class="lo-marketplace_title" href="https://ad.doubleclick.net/ddm/clk/403652017;203869784;k" rel="nofollow" target="_blank" onClick="trackEvent('Marketplace', 'Click', '1968 Tableau Software');" >
				Free Whitepaper! The 5 criteria to help you select the right analytics platform for your organization.
			</a>
		</li>
	
		<li class="lo-marketplace_item">
			<a class="lo-marketplace_image" href="https://ad.doubleclick.net/ddm/clk/403638972;203868065;p" rel="nofollow" target="_blank" onClick="trackEvent('Marketplace', 'Click', '1967 Tableau Software');" >
				<img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20171129113953" data-src="https://d321cxw853vaeo.cloudfront.net/marketplace/100x42/marketplace/tableau_logo_1.jpg" />
			</a>
			<a class="lo-marketplace_title" href="https://ad.doubleclick.net/ddm/clk/403638972;203868065;p" rel="nofollow" target="_blank" onClick="trackEvent('Marketplace', 'Click', '1967 Tableau Software');" >
				Free Whitepaper! Learn how IT is evolving from producer to enabler, and fostering collaboration around analytics.
			</a>
		</li>
	
		<li class="lo-marketplace_item">
			<a class="lo-marketplace_image" href="https://ad.doubleclick.net/ddm/clk/403654357;203907336;f" rel="nofollow" target="_blank" onClick="trackEvent('Marketplace', 'Click', '1969 Tableau Software');" >
				<img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20171129113953" data-src="https://d321cxw853vaeo.cloudfront.net/marketplace/100x42/marketplace/tableau_logo_3.jpg" />
			</a>
			<a class="lo-marketplace_title" href="https://ad.doubleclick.net/ddm/clk/403654357;203907336;f" rel="nofollow" target="_blank" onClick="trackEvent('Marketplace', 'Click', '1969 Tableau Software');" >
				Free Whitepaper! Learn how to create an analytics environment that is governed, scalable and self-serve.
			</a>
		</li>
	
	</ul>
</section>










  </div><!-- content_wrap -->




</div><!-- main -->
</div><!-- skin -->


<footer class="lo-footer">
  <div class="lo-footer_content">
    <div class="lo-footer_nav">
      <ul class="lo-footer_nav_list">
        <li><a href="/contacts">Editorial Contacts</a></li>
        <li><a href="http://www.idg.com.au/contacts">Advertising Information</a></li>
        <li><a href="/privacy">Privacy Policy</a></li>
        <li><a href=>RSS</a></li>
        <li><a href="/user/mailing_list/?referrer=footer_links">Newsletters</a></li>
        <li><a href="/event/calendar">Events</a></li>
        <li><a href="/section/featured_whitepapers">Whitepapers</a></li>
        <li><a href="/tax/news">News</a></li>
        <li><a href="/zones">Zones</a></li>
        <li><a href="/mediareleases/">IT Media Releases</a></li>
        <li><a href="/index.php/ssid;all">Slideshows</a></li>
        <li><a href="/video/">Videos</a></li>
      </ul>
    </div>
    
    <div class="lo-footer_bottom">
        <p class="lo-copyright">Copyright 2017 IDG Communications. ABN 14 001 592 650. All rights reserved. Reproduction in whole or in part in any form or medium without express written permission of IDG Communications is prohibited.</p>

        <div id="footer_sites">
          IDG Sites:
          <a href="http://www.pcworld.idg.com.au">PC World</a> | 
          <a href="http://www.goodgearguide.com.au">GoodGearGuide</a> | 
          <a href="http://www.cio.com.au">CIO</a> |
          <a href="http://www.cmo.com.au">CMO</a> |
          <a href="http://www.cso.com.au">CSO</a> | 
          <a href="http://www.techworld.com.au">Techworld</a> | 
          <a href="http://www.arnnet.com.au">ARN</a> | 
          <a href="http://www.cioexecutivecouncil.com.au/">CIO Executive Council</a>
        </div>
    </div>
    
    
  </div>
</footer>




<div id="ad_slot"></div>

<div class="lo-scripts">

  <script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/lazysizes.min.js?release=20171129113953"></script>
  <script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/rohan_world/rohan_world.js?release=20171129113953"></script>

  
  <div class="ad_scripts">
  
<div class="gpt-ad" id="gpt-ad-skin-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[1600, 1]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 100], [[1600, 1]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>


  
<div class="gpt-ad" id="gpt-ad-over-the-page-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[1, 1]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 610], [[1, 1]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>


  
<div class="gpt-ad" id="gpt-ad-gumgum-in-image-ad-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[12, 12]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[0, 0], [[12, 12]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>


  
<div class="gpt-ad" id="gpt-ad-mobile-otp-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[2, 2]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 610], []], [[0, 0], [[2, 2]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>


  
<div class="gpt-ad" id="gpt-ad-mobile-floating-banner-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[320, 50]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[600, 800], []], [[0, 0], [[320, 50]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>


  
<div class="gpt-ad" id="gpt-ad-third-party-otp-3081940" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ComputerWorld.com.au/machine_learning_and_ai_section" data-gpt-sizes="[[15, 15]]" data-gpt-targeting='{&quot;node&quot;: [&quot;630516&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;cw&quot;], &quot;kw&quot;: [&quot;processes&quot;, &quot;reducing&quot;, &quot;service&quot;, &quot;dell&quot;, &quot;analytics&quot;, &quot;learning&quot;, &quot;enterprise&quot;, &quot;performance&quot;, &quot;data+integration&quot;, &quot;data&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;sect&quot;: [&quot;machine_learning_and_ai&quot;, &quot;data&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[0, 0], [[15, 15]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



  
  <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/c1f8d.js?release=20171129113953" charset="utf-8"></script>
  <script type="text/javascript">
  createAndDisplayAds();
  </script>
  </div>
  

<!--   <script type="text/javascript">
  $(".disqus-comment-count").bind('disqus-counts-loaded', function() {
    var obj = $(this);

    if (obj.text() == "0 Comments") {
      obj.text("").hide();
    }
  });
  </script> -->

  <script type="text/javascript">
var disqus_shortname = 'computerworldau';

/*
(function () {
var s = document.createElement('script'); s.async = true;
s.type = 'text/javascript';
s.src = 'http://' + disqus_shortname + '.disqus.com/count.js';
(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
}());
*/

// This lets us know when the JS has loaded and after the counts are fetched.
function disqus_counts_loaded() {
	DISQUSWIDGETS.old_displayCount = DISQUSWIDGETS.displayCount;

	// Override the old displayCount() with a new one so we can attach our helper onto it.
	DISQUSWIDGETS.displayCount = function(arg) {
		DISQUSWIDGETS.old_displayCount(arg);
		$("a[href$=#disqus_thread],*[data-disqus-identifier]").trigger('disqus-counts-loaded');
	}
}

$.getScript('//' + disqus_shortname + '.disqus.com/count.js', disqus_counts_loaded);
</script>


  <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/rohan_world/data3hack.js?release=20171129113953"></script>

  <div id="fb-root"></div>
<script>
	window.fbAsyncInit = function() {
		FB.init({appId: '111663785542285', status: true, cookie: true,
			xfbml: true});
	};
	(function() {
		var e = document.createElement('script'); e.async = true;
		e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
		document.getElementById('fb-root').appendChild(e);
	}());
</script>

  <div id="trackers">
    
<!-- Start Google Analytics  -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-4682850-1', 'auto');

ga('require', 'displayfeatures'); // enables demographics and interests reports


	ga('set', 'dimension1', "none");



	ga('set', 'dimension2', "eric-thoo-research-director-at-gartner");



	ga('set', 'dimension3', "none");



	ga('set', 'dimension4', "none");



	ga('set', 'dimension5', "anonymous");



	ga('send', 'pageview');


// pageTracker._trackPageLoadTime();


// event tracking is asynchronous
function trackEvent(category, action, label, value) {
	if (value)
		ga('send', 'event', category, action, label, value, {'nonInteraction': 1});
	else
		ga('send', 'event', category, action, label, {'nonInteraction': 1});
}



trackEvent('Brand Posts', 'Brand Post native ad impression', 'brand-post-nid-628470');



</script>
<!-- End Google Analytics -->


    &lt;img height=&quot;1&quot; width=&quot;1&quot; style=&quot;border-style:none;&quot; alt=&quot;&quot; src=&quot;//insight.adsrvr.org/track/evnt/?adv=bitgblf&amp;ct=0:jkis3bum&amp;fmt=3&quot;/&gt;
  </div>

  
  
  <!-- Crazy Egg Tracking -->
  <script type="text/javascript">
  setTimeout(function(){var a=document.createElement("script");
  var b=document.getElementsByTagName("script")[0];
  a.src=document.location.protocol+"//script.crazyegg.com/pages/scripts/0018/8767.js?"+Math.floor(new Date().getTime()/3600000);
  a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);  
  </script>
  

  
<!-- IDGAU Async BlueKai init v -->
<!-- Begin BlueKai Tag -->
<script type="text/javascript">
function getBlueKaiDynamicKeyValues() {
  return $.ajax({
    url: "/script-tagger/bluekai/json/",
    dataType: "json",
    async: true,
    timeout: 700
  });
}

function addBlueKaiDynamicKeyValues(data) {
  $.each(data, function(key, value) {
    //console.log('bluekai targeting ' + key + ':' + value);
    bk_addPageCtx(key, value);
  });
}

// window.bk_async function is called once bluekai script has loaded
window.bk_async = function() {
bk_addPageCtx("idgau_all", "yes");



  bk_addPageCtx("cmscatnms", "[machine_learning_and_ai,data]");

  // Add dynamic profile context values. Required to cache pages in the cdn. 
  getBlueKaiDynamicKeyValues().then(function(data, textStatus, jqXHR){
    // Successfully retrieved dynamic key values
    return addBlueKaiDynamicKeyValues(data); 
  },
  function(data, textStatus, jqXHR){
    console.log('Failed retrieving bluekai dynamic key values - ' + textStatus);
  }).then(function(){
    //console.log('execute blue kai');
    BKTAG.doTag(19641, 4); 
  });
};


(function() {
  var scripts = document.getElementsByTagName('script')[0];
  var s = document.createElement('script');
  s.async = true;
  s.src = "https://tags.bkrtx.com/js/bk-coretag.js";
  scripts.parentNode.insertBefore(s, scripts);
}());
</script>
<!-- End BlueKai Tag -->


  

<script type="text/javascript">
var clicky_site_ids = clicky_site_ids || [];
clicky_site_ids.push(100848091);
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript';
  s.async = true;
  s.src = '//static.getclicky.com/js';
  ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
})();
</script>
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/100842788ns.gif" /></p></noscript>

  <script type='text/javascript'>
    var _sf_async_config={};
    /** CONFIGURATION START **/
    _sf_async_config.uid = 60734;
    _sf_async_config.domain = 'computerworld.com.au';
    _sf_async_config.useCanonical = true;
    _sf_async_config.sections = 'Machine learning and AI,Data';  //CHANGE THIS
    _sf_async_config.authors = 'Eric Thoo, research director at Gartner';    //CHANGE THIS
    /** CONFIGURATION END **/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
         loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>

  <!-- Twitter universal website tag code -->
<script>
!function(e,n,u,a){e.twq||(a=e.twq=function(){a.exe?a.exe.apply(a,arguments):
a.queue.push(arguments);},a.version='1',a.queue=[],t=n.createElement(u),
t.async=!0,t.src='//static.ads-twitter.com/uwt.js',s=n.getElementsByTagName(u)[0],
s.parentNode.insertBefore(t,s))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','nv5jw');
twq('track','PageView');
</script>
<!-- End Twitter universal website tag code -->

  
  
<!--   <script>
    var disqus_shortname = "";
  </script> -->
  <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/jquery.magnific-popup.min.js?release=20171129113953"></script>
  <script src="https://www.idgcdn.com.au/compressor-staticfiles/article/jquery-ias.min.js?release=20171129113953"></script>
  <script src="https://www.idgcdn.com.au/compressor-staticfiles/article/jquery.adaptive-backgrounds.js?release=20171129113953"></script>
  <script>
    ias_init('Computerworld');
  </script>


</div>


</body>
</html>
