Ruby on Rails upgrade released

Popular Web framework gets improved support for HTTP validators as well as an internalization framework

Ruby on Rails 2.2, an upgrade to the popular Web application framework, was released Friday, featuring an internationalization framework and stronger support for HTTP validators, according to the Ruby on Rails Web site.

With a full-on internationalization framework, internationalization is offered by default. Support for HTTP validators is provided in the form of etag and last-modified, according to the site. This can make it easier to skip expensive processing and also makes it easier to use gateway proxies.

Also featured are thread safety and a connection pool for the Active Record capability in Rails. "So now all elements of Rails are thread-safe, which is a big boon for the JRuby guys in particular," a blog on the site stated. "For C Ruby, we still need a bunch of dependent libraries to go non- blocking before it'll make much of a difference, but work on that is forthcoming."

Rails 2.2 also features improved API docs and a new guides section. It is compatible with Ruby 1.9 and JRuby.

Connection pooling in version 2.2 enables Rails to distribute requests across a pool of databases, according to release notes for the framework. Transactional migrations in version 2.2 are supported on PostgreSQL out of the box. The code will be extensible to other database types in the future, the notes said.

The framework can be installed through the RubyGems packaging system for Ruby.

Ruby on Rails was created by David Heinemeier Hansson, and Ruby and Ruby on Rails were featured at last week's QCon conference in San Francisco.

Join the newsletter!

Error: Please check your email address.

Tags ruby on rails

More about Gateway

Show Comments