Update: Overflowable buffer in earlier versions of glibc

LinuxToday reports an overflowable buffer exists in earlier versions of glibc glob(3) implementation. It may be possible to exploit programs that pass user modifiable input to the glibc glob function.

Relevant releases/architectures:

Red Hat Linux 6.2 - alpha, i386, i686, sparc, sparcv9.

Red Hat Linux 7.0 - alpha, alphaev6, i386, i686.

Red Hat Linux 7.1 - alpha, alphaev6, i386, i686, ia64.

Red Hat Linux 7.2 - i386, i686.

More infor at http://linuxtoday.com/news_story.php3?ltsn=2001-12-14-016-20-SC-RH

Join the newsletter!

Or

Sign up to gain exclusive access to email subscriptions, event invitations, competitions, giveaways, and much more.

Membership is free, and your security and privacy remain protected. View our privacy policy before signing up.

Error: Please check your email address.

More about Red Hat

Show Comments