Bitmap file handling vulnerability in Photoshop

A vulnerability has been revealed in the way Adobe Photoshop CS2 and CS3 handles Bitmap files (e.g. .BMP, .DIB, .RLE). The error can be exploited to cause a stack-based buffer overflow via a specially crafted Bitmap file, and could potentially allow execution of arbitrary code. Users are warned not to open untrusted Bitmap files.

More information is available from Secunia.

Join the newsletter!

Or
Error: Please check your email address.

More about Adobe SystemsCs3VIA

Show Comments