Microsoft Japan ex-MD accused of tax evasion

A warning about the security flaw identified last Monday in the zlib compression/decompression library affecting Linux systems has been broadened to include Windows and any other other operating systems that use the zlib code.

In an update about the flaw on their Web site, the authors of the zlib library said they have learned that the code is used in far more programs than they originally believed.

"The use of zlib has apparently reached pandemic proportions," according to the statement from co-authors Mark Adler and Jean-loup Gailly. "Before the research in February and March of 2002 on this vulnerability, even the authors of zlib had no clue how widespread the use of zlib has become."

A list of affected applications on the site includes Microsoft Corp.'s DirectX 8, FrontPage, GDI+, Internet Explorer, Office, NetShow, Train Simulator, Visual Studio and Windows Messenger. It also includes Netscape Navigator, Network Associates Inc.'s PGP security software, Symantec Corp.'s Norton Antivirus and Jasc Software Inc.'s PaintShop Pro.

The zlib library is a data compression and decompression program that helps speed network file transfers. The problem, uncovered recently by a researcher at Linux vendor Red Hat Inc., is that a memory allocation routine built into the program tries to free used memory twice.

According to the library's authors, "On many systems, freeing the same memory twice will crash the application. Such 'double free' vulnerabilities can be used in denial-of-service attacks, and it is remotely possible that the vulnerability could be exploited in some applications to execute arbitrary code with that application's permissions."

They said that so far there have been no reports that the security flaw, first made public on Monday, March 11, has been exploited.

Dave Wreski, director at Guardian Digital Inc., an open-source security company in Saddle River, N.J., said zlib is also used in embedded applications, so the effects of any security flaw would be wide-reaching.

A new version of zlib that corrects the problem is available in source code from the zlib Web site, and patches are available from vendors including Red Hat, embedded Linux software company MontaVista Software Inc. and others.

Join the newsletter!

Error: Please check your email address.

More about Guardian DigitalJasc SoftwareMicrosoftNetwork Associates InternationalPandemicPGPPGP SecurityRed HatSymantec

Show Comments

Market Place