Adobe patches critical vulnerabilities in Flash Player, Shockwave

An exploit targets one of the vulnerabilities by using Flash content embedded in Microsoft Word documents, Adobe warns

Adobe patched several vulnerabilities in its Flash Player and Shockwave Player on Tuesday, including one for which an exploit is already available.

"Adobe is aware of reports that an exploit designed to trick the user into opening a Microsoft Word document with malicious Flash (.swf) content exists for CVE-2013-5331," the company said in a security advisory.

That CVE (Common Vulnerabilities and Exposures) ID refers to a type confusion vulnerability fixed in the new version of Flash Player. A memory corruption flaw tracked as CVE-2013-5332 was also fixed. If exploited successfully, both vulnerabilities can lead to arbitrary code execution allowing attackers to take control of the affected systems.

Some mitigation for this type of exploit exists since Flash 11.6, which introduced a click-to-play feature that requires users to confirm the playback of Flash content embedded in documents when opened in Microsoft Office versions older than Office 2010.

Tuesday's update, though, moved the Windows and Macintosh versions of Flash Player to version 11.9.900.170, and the Linux version to 11.2.202.332. The Flash Player versions bundled with Google Chrome, Internet Explorer 10 and Internet Explorer 11 will automatically be updated through those browsers' update mechanisms.

The two Flash Player vulnerabilities were also fixed in Adobe AIR, a runtime for rich Internet applications that has Flash support. The patches are included in Adobe AIR version 3.9.0.1380 for Windows, Mac and Android.

Adobe Shockwave Player version 12.0.7.148 for Windows and Mac was released Tuesday to resolve two different memory corruption vulnerabilities -- CVE-2013-5333 and CVE-2013-5334 -- that could lead to arbitrary code execution. Shockwave Player is not as widespread as Flash Player, but it is installed on over 450 million desktop computers, according to Adobe, which makes it a potential target for attackers.

Since there are reports of an existing exploit for one of the two Flash vulnerabilities, "our recommendation is to include the Flash release in your 'patch urgently' category," Wolfgang Kandek, CTO of vulnerability management firm Qualys, said in a blog post.

Join the Computerworld Australia group on Linkedin. The group is open to IT Directors, IT Managers, Infrastructure Managers, Network Managers, Security Managers, Communications Managers.

More about: Adobe, Google, Linux, Microsoft, Qualys
Comments are now closed.
Related Coverage
Related Whitepapers
Latest Stories
Community Comments
Tags: patches, security, Adobe Systems, patch management, Exploits / vulnerabilities
Whitepapers
All whitepapers

10 Big Data startups to watch

READ THIS ARTICLE
DO NOT SHOW THIS BOX AGAIN [ x ]
Sign up now to get free exclusive access to reports, research and invitation only events.

Computerworld newsletter

Join the most dedicated community for IT managers, leaders and professionals in Australia