ISC patches BIND denial-of-service flaw that crashed servers worldwide

The patch for a zero-day denial-of-service flaw in BIND prevents crashes, but doesn't fix the actual vulnerability

The Internet Systems Consortium (ISC), an organization that maintains several software products critical for Internet infrastructure, has released a patch for an actively exploited denial-of-service vulnerability in the widely used BIND DNS server.

ISC launched an investigation into the issue Wednesday after many organizations around the world reported that their BIND 9-based DNS resolvers crashed unexpectedly. For example, judging by the comments posted in response to an Internet Storm Center alert, dozens of universities across the U.S. experienced the problem.

The DNS (Domain Name System) is used to translate domain names into IP (Internet Protocol) addresses, computers and network devices querying the defined DNS servers each time a website is accessed.

These DNS resolvers query other servers further up the chain in order to retrieve the correct answers. To speed up the process for future queries, the answers are cached locally for a period of time.

ISC determined that the crashes are the result of an inconsistent record being cached and then served to clients. It's not yet clear what kind of network event causes the BIND resolvers to cache the malformed record in the first place.

It could be either a deliberate attack or an unintended anomaly, but according to Carsten Eiram, chief security specialist at vulnerabilty research company Secunia, the first scenario is more likely. "Based on the public reports and information we've received, it seems to be caused by malicious attacks," he said.

ISC has issued a patch to stop the crashes from occurring. It consists of two components, one preventing the server from returning inconsistent data from cache and the other preventing the server from crashing when it receives malformed answers.

However, this is just a bandage and doesn't fix the actual vulnerability. "The current patches only prevent the crash, but do not fix the core problem," Eiram said. "We are also currently analyzing the vulnerability in order to determine the core problem."

Fortunately, according to the vulnerability expert, there are no reasons to believe that the vulnerability could also have code execution potential, which would make it much more dangerous.

System and network administrators are strongly encouraged to upgrade their BIND installations to the newly released 9.8.1-P1, 9.7.4-P1, 9.6-ESV-R5-P1 or 9.4-ESV-R5-P1 versions, depending on which branch they use.

Tags securityInternet Systems ConsortiumExploits / vulnerabilities

More about etworkSecunia

Comments

Comments are now closed

Atlassian CEO gets why startups want to leave Australia

READ THIS ARTICLE
MORE IN Business
DO NOT SHOW THIS BOX AGAIN [ x ]